Currently methods are named * options * positionals * option(char), option(String) * positional(int) * hasOption(char), hasOption(String), hasOption(OptionSpec) * hasPositional(int), hasPositional(PositionalParamSpec) These should all be prefixed with `matched`, so `matchedOptions`, `hasMatchedOption` etc. This helps to clarify the semantics of #340 and #341 .