-
Notifications
You must be signed in to change notification settings - Fork 124
Fixed: Drawer Ttile #4801
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Fixed: Drawer Ttile #4801
Conversation
col: this.col, | ||
row: this.row, | ||
cellValue: this.cellValue | ||
}) | ||
} | ||
|
||
let title = this.cellValue || this.row.name | ||
|
||
const resource = this.getResource() | ||
|
||
if (resource) { |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
There doesn't seem to be any known issues with this code snippet, it seems very basic and straightforward. In terms of optimization, you could consider making the title
variable local instead of using col
, row
or cellValue
inside the formatter argument method (this.formatterArgs.getDrawerTitle({})
). The current use of "col" is not necessary because it's already used in your resource path.
Regarding differences between previous versions (October 2021), there aren't clear changes indicated beyond these few lines that don't significantly impact readability/efficiency but which can potentially save on resources by improving performance.
If anything more complex needs checking please ask, I'm here for any clarification!
@@ -52,6 +55,9 @@ export default { | |||
getTitle({ row }) { | |||
return row.account.username | |||
}, | |||
getDrawerTitle({ row }) { | |||
return row.account.username | |||
}, | |||
getRoute({ row }) { | |||
return { | |||
name: 'AssetAccountDetail', |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
None of these differences seem to be related to coding standards or errors in the code snippet provided. The only difference is that "getDrawerTitle" function has been renamed, and "getRouteName" method was restructured with a different structure.
The code is generally clean and well-written without obvious issues. However, it's recommended to perform further checks on the implementation based on updated project requirements.
getRoute: ({ row }) => ({ | ||
name: 'AccountPushDetail', | ||
params: { id: row.automation.id } | ||
}), | ||
getDrawerTitle({ row }) { | ||
return row.automation.name | ||
return row.automation?.name | ||
} | ||
}, | ||
id: ({ row }) => row.automation |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
There doesn't appear to be any obvious coding inconsistencies, potential issues or optimizations that need to be checked here. The code appears to use standard React practices and syntax, and there's no apparent context of a specific environment like testing frameworks or development tools. Therefore, I cannot see anything requiring clarification beyond the initial observation of no errors present.
The key pieces of information from the provided text (and as it stands) do not reveal significant irregularities, issues or opportunities for optimization within the current code structure. It simply lists components with names such as getDrawerTitle
, getTitle
, drawer
etc. which would imply functionality related to navigation or user interaction rather than an actual defect in production code.
However, should you ask specifically about some aspect of these component properties like naming conventions, function definitions or if they follow standards or guidelines established previously, I'd have to review those details further before providing feedback since they're out-of-context without a clearer statement describing their purpose or usage.
|
Fixed: Drawer Ttile