-
Notifications
You must be signed in to change notification settings - Fork 124
perf: Translate #4733
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
perf: Translate #4733
Conversation
has: !this.row.present | ||
}, | ||
{ | ||
name: 'change_password_add', | ||
label: this.$t('Add account after changing password'), | ||
label: this.$t('AddAccountAfterChangingPassword'), | ||
has: !this.row.present | ||
} | ||
] |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
The code appears to be fine as there don't seem to be any significant changes or bugs that require attention. The key difference is regarding the translation keys used (from "Delete remote account" to "", "Add account after changing password", and so on) which are consistent with how they should appear in a localized version of the UI. However, if you need further adjustments or translations, please let me know!
hidden: true, | ||
meta: { | ||
title: i18n.t('AccountDiscoverAccountDetail'), | ||
title: i18n.t('DiscoverAccountDetail'), | ||
permissions: ['accounts.view_gatheraccountsexecution'] | ||
} | ||
} |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
The only difference between the original version and current version is that all of them use "i18n" instead of "lgbm", hence there isn't really an issue but just a typo, not necessarily irregularity.
Optimization Suggestions:
As no additional requirements were provided for optimization, the suggestion would be to review if any changes are needed, and perhaps refactor the code structure (if necessary) keeping readability and efficiency in mind.
@@ -41,7 +41,7 @@ export const gatherAccountTableConfig = (vm, url) => { | |||
can: true, | |||
getRoute({ row }) { | |||
return { | |||
name: 'AccountDiscoverAccountDetail', | |||
name: 'DiscoverAccountDetail', | |||
params: { id: row.id } | |||
} | |||
}, |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
No, there is no indication of any inconsistencies or errors found in this given code snippet. It appears to be correctly formatted with the necessary imports and logical structure.
However, it's important to note that my assessment can potentially overlook specific issues if I am not fully aware of all relevant context. For further checks, we would need more comprehensive feedback from other developers or experts familiar with these components.
|
perf: Translate