-
-
Notifications
You must be signed in to change notification settings - Fork 6k
improve github downloader on migrations #7049
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
improve github downloader on migrations #7049
Conversation
Codecov Report
@@ Coverage Diff @@
## master #7049 +/- ##
==========================================
+ Coverage 41.72% 41.74% +0.02%
==========================================
Files 443 443
Lines 60159 60149 -10
==========================================
+ Hits 25103 25112 +9
+ Misses 31780 31762 -18
+ Partials 3276 3275 -1
Continue to review full report at Codecov.
|
modules/migrations/git.go
Outdated
func (g *PlainGitDownloader) GetIssues(start, limit int) ([]*base.Issue, error) { | ||
return nil, ErrNotSupported | ||
// GetIssues returns issues according page and PerPage | ||
func (g *PlainGitDownloader) GetIssues(page, PerPage int) ([]*base.Issue, bool, error) { |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
pageSize
would be better name imho
func (g *PlainGitDownloader) GetIssues(page, PerPage int) ([]*base.Issue, bool, error) { | |
func (g *PlainGitDownloader) GetIssues(page, pageSize int) ([]*base.Issue, bool, error) { |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
The name is from github's API document. :)
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Method argument then should be at least lowercase first letter
bd1fe0e
to
95781d7
Compare
@lafriks done. |
* improve github downloader on migrations * fix tests * fix uppercase function parameters
The new interface will make code easier to understand.